Support Forum

Archiv:
 
  • Selection > Align on grid

    Hello.

     

    I seem to be having an issue with the Selection > Align on grid command.

    I'm using an Intel Mac, my units are in inches, and my grid is set to 0.125"

     

    For an example....

    Create a 0.25" drill hole and set the origin to be the center of the hole

    Create a second drill hole and type in the coordinates for X=5.0000", Y=0.0000

    Right-click the second hole and select "Align on grid" (or Selection > Align on grid)

     

    The second hole is moved to X=0.5016

     

    Anybody else having a similar issue?

     

    Thanks!

    Posted By: Seth Alder on Nov 16, 2010 10:21PM Category: Front Panel Designer

    Hello Seth,

     

    Thank you for contacting us about Front Panel Designer.

     

    Can you describe for me the manner in which you are setting the origin to be the center of the hole?

     

    Is the setting "Align to Grid" checked in the "View" menu? If you set the first hole and/or the origin locations without having automatic alignment to the grid, then you would incur an issue like this.

     

    In actuality, it is generally easier to simply leave the origin in a corner, then use the "Move" function to specify the spacing between two holes with the "Apply to Copy" box checked.

     

    I look forward to receiving more information regarding this issue.

     

    Kindest Regards,

     

    Paul Birkeland

    Customer Service

    Posted By: Paul Birkeland on Nov 16, 2010 10:46PM

    Reply

    Hi Paul,

     

    Can you describe for me the manner in which you are setting the origin to be the center of the hole?

     

    I set the origin to the center of the hole using the "Set origin" tool and the option selected for "Enter coordinates based on the reference point of an object". Then I click the center of the hole. This makes the hole X=0.0000", Y=0.0000".

     

    Is the setting "Align to Grid" checked in the "View" menu? If you set the first hole and/or the origin locations without having automatic alignment to the grid, then you would incur an issue like this.

     

    I do have "Align to Grid" checked in the "View" menu.

     

    In actuality, it is generally easier to simply leave the origin in a corner, then use the "Move" function to specify the spacing between two holes with the "Apply to Copy" box checked.

     

    The move command works well, thanks for the tip. (By the way, the key command is listed as "cmd M," but it actually seems to be just "M" on my Mac).

     

    Even if I leave the origin at the lower left corner of the panel (Origin X: 0.0000", Origin Y: 0.0000" under the Edit > Settings menu), I still have the same issue with the "Align on grid" command.

     

    For example...

    Origin is set to its original location: X=0, Y=0 on the lower left of the panel

    Grid set to 0.125"

    Move an object to X=1", Y=1" using the "Move" command

    Right click the object and select "Align on grid"

    The object is moved to X=0.9997", Y=0.9997"

     

    Thanks for your help!

     

    Seth

    Posted By: Seth Alder on Nov 16, 2010 11:35PM

    Reply

    Hello again Seth,

     

    We are unable to replicate these issues on our Windows version, but we will double check on the Mac for you tomorrow.

     

    Kindest Regards,

    Paul Birkeland

    Customer Service

    Posted By: Paul Birkeland on Nov 18, 2010 01:10AM

    Reply

    Hi Paul,

     

    Thanks for checking on this. While you are at it, you might want to try out the key commands that seem to be malfunctioning. Here's my list so far...

     

    Delete key - does not delete a selected object

    Cmd M - does not open the Move dialog (but M does)

    Space bar - does not activate to the Select mode tool

    Shift Cmd M - seems to be buggy - only opens the Macro objects panel sometimes

     

    Best,

    Seth

    Posted By: Seth Alder on Nov 18, 2010 05:06AM

    Reply

Please enter your message:

* = required field

  •   
  •   
 
  
Facebook Linked In Youtube Google+