Support Forum

Archiv:
 
  • Category Tree is Corrupt

    Hi, I thought I'd leverage the macro folders and add my own folder. When I did that I got an error that the "category tree is corrupt!". It did not add my folder.

     

    Subsequently, everytime I tried to add a new macro object the error comes up (I'm not even trying to create a new folder at this point). Yes, I did quit and restart the program and the error remains in this file.

     

    Further, when I tried to rename a macro object, the program crashed completely.

     

    Don't know if this has been reported, or if files can get corrupted, but I hope not because I've spent a lot of hours on this file. Please advise.

     

    Thank-you,

     

    Mike

    Posted By: Mike Phillips on Dec 18, 2010 08:49AM Category: Front Panel Designer

    Note: I tried uninstalling the programl, rebooting, and then reinstalling...definitely still have the problem.

     

    Further, the problem manifests in other files I open as well. Somehow my macro library is corrupted. Any fixes to this?

     

    Thank-you,

     

    Mike

    Posted By: Mike Phillips on Dec 18, 2010 08:56AM

    Reply

    Hello Mike,

     

    Thank you for reporting this issue. Can you list the specifications of your computer, including hardware and operating system?

     

    Also, which version of Front Panel Designer are you using?

     

    Was the attempt to add a folder to the Macros menu done in the software or in the program directory itself?

     

    Thanks for the additional information. We will attempt to recreate the issue if possible, and it will be reported either way.

     

    Kindest Regards,

    Paul Birkeland

    Customer Service

    Posted By: Paul Birkeland on Dec 20, 2010 06:37PM

    Reply

    Hi Paul, thank-you.

     

    Computer: Win 7 x64, Core I7 920 processor

     

    Front Panel software: 4.1

     

    Method for adding folder: done in the software itself.

     

    I get the error no matter what file I open, so I believe the program itself is corrupt somehow.

     

    I did try uninstalling/reinstalling it, but that didn't help.

     

    I have not touched the folders structure on the hard drive.

     

    Glad to know this is not a rampant problem; any thoughts on a fix? If not, I can live with it; but it is annoying. It also has removed the Standard directory and all I have is the user directory.

     

    Thanks,

     

    mike

    Posted By: Mike Phillips on Dec 20, 2010 11:17PM

    Reply

    Update.

     

    Simply uninstalling/reinstalling the program has not worked.

     

    After many unsuccessful attempts to get this working again, here is what worked and finally fixed the problem:

     

    1) I deleted the reference to my custom macro folder (Macro files option in the settings under Edit.)

     

    2) Uninstalled the program

     

    3) Removed all references to SchaefferAG in the registry

     

    4) Deleted the whole Users/Username/AppData/Roaming/FrontDesign folder (which had contained the personal macros).

     

    5) Reinstalled the program.

     

    This worked.

     

    When this corruption occurred, I was not doing any funny business; I simply tried to make my own folder for a macro, using the new folder button in the macros pane, and immediately all the trouble started.

     

    Now, however, I am able to add my own categories without an error. I don't know why this occurred, but I trust you will log it and the fix in case this comes up again.

     

    Thank-you,

     

    Mike

    Posted By: Mike Phillips on Dec 21, 2010 10:47AM

    Reply

    Hello again Mike,

     

    Thank you for following up on this problem; your complete report will be very helpful for our software developers.

     

    If you right click on the "User" directory in the macro pane and select "Import Old Macros", are you able to bring your old macros back into the software?

     

    I suspect there was just a small hiccup during the installation of the newest version of the software, and your efforts to clean out the original software version entirely allowed the new installation to perform as intended.

     

    Kindest Regards,

    Paul Birkeland

    Customer Service

    Posted By: Paul Birkeland on Dec 21, 2010 05:23PM

    Reply

Please enter your message:

* = required field

  •   
  •   
 
  
Facebook Linked In Youtube Google+